新闻  |   论坛  |   博客  |   在线研讨会
YOCTO问题汇总
电子禅石 | 2020-12-01 19:43:11    阅读:3243   发布文章
编译平台:ubuntu 18.04
root用户编译出现一个root问题
error1:
ERROR:  OE-core's config sanity checker detected a potential misconfiguration.
    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
    Following is the list of potential problems / advisories:

    Do not use Bitbake as root.
 
解决方法:
注释掉yocto-bsp/sources/poky/meta/classes/sanity.bbclass文件里以下几句
    #if 0 == os.getuid():
    #    raise_sanity_error("Do not use Bitbake as root.", d)
error2:
ERROR: gnu-config-native-20150728+gitAUTOINC+b576fa87c1-r0 do_unpack: Function failed: Fetcher failure: Fetch command failed with exit code 128, output:
fatal: the '--set-upstream' option is no longer supported. Please use '--track' or '--set-upstream-to' instead.

ERROR: Logfile of failure stored in: /home/leo/work/imx6/genivi-imx6/build-genivi/tmp/work/x86_64-linux/gnu-config-native/20150728+gitAUTOINC+b576fa87c1-r0/temp/log.do_unpack.3948
 
解决办法:
    1. 更新git
     2. 修改sources/poky/bitbake/lib/bb/fetch2/git.py
                #runfetchcmd("%s branch --set-upstream %s origin/%s" % (ud.basecmd, branchname, \
                #            branchname), d)
                to
                runfetchcmd("%s branch --set-upstream-to origin/%s" % (ud.basecmd, \
                            branchname), d


*博客内容为网友个人发布,仅代表博主个人观点,如有侵权请联系工作人员删除。

参与讨论
登录后参与讨论
属于自己的技术积累分享,成为嵌入式系统研发高手。
推荐文章
最近访客